
Clipboard

The Windows "clipboard" is a temporary storage area that can be used to move information 
from one application program to another or from one area in a file or buffer to another.    
Information is inserted into the clipboard by a Cut or a Copy operation.    Information is 
retrieved from the clipboard by a Paste



Cut

The Cut operation removes the selected and highlighted data from an application and 
inserts it into the Windows clipboard. 



Copy

The Copy operation copies the selected and highlighted data from an application and inserts
it into the Windows clipboard.      The selected text remains in the application as well as in 
the clipboard at the end of this operation.



Paste

The Paste operation moves the data from the Windows clipboard and copies it into the 
application program at the current insertion point.. 



results buffer

The results buffer is the text displayed in the lower portion of the FSRCH window.    It 
describes the files that were searched and the search keys that were matched.    This buffer 
may be edited, printed, or "clipped" to the clipboard.    

Each line in the results buffer which describes a batch of the search criteria includes a byte 
count where the match was found, an optional text line count, and a portion of the text 
around the match to put it in context.    If any ASCII control characters (e.g. line feed or 
carriage return) appear in the displayed text, they will appear as filled in squares.    If the 
results text is "clipped" and transferred to a file, the control characters will retain their 
original values.



FSRCH

The ultimate File Search Utility program.    This program is available in both DOS and 
Windows versions.    It is produced by Leeson Software services and is available through 
better Shareware distributors everywhere.



search key

A search key is a text string used to identify matching portions of the files that are searched. 
A file may be searched for the presence of a string or for a relationship between two search 
keys.



search mode

The search mode determines how one or both of the possible search keys will be used in 
identifying "matches" in the target files.    A search mode can be simply the presence of one 
of the search keys, or it can be the occurrence of a defined relationship between the two 
keys within the contents of the file.



file selector

The file selector identifies one or more file path and name patterns that must be matched 
before a file will be considered a candidate to be searched.    If the file selector consists of a 
list of file patterns, they should be delimitted with commas.



search options

The search options identify any special processing that must be applied during the file 
searches.    These include ignoring text case, stripping the top bit of the characters, showing 
search progress, listing line numbers, writing the results to a file, searching all subdirectories
within the defined search path etc.
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The Index contains a list of all Help topics available for FSRCH/Windows. For information on 
how to use Help, press F1 or choose Using Help from the Help menu.    The Search mode in 
the help system allows you to examine the help text directed by stringwords.



Date Restrictions
You may restrict the directory date on files selected for searching to be either before an 
indicated date or after the date that you provide.    Once you select a mode of date 
restriction, Fsrch/Windows will prompt you for the date that file dates are to be compared to. 
Files whose dates exactly match the indicated date will be considered to be candidates if the
AFTER restriction is selected, but will not be condidates for searching if the BEFORE 
restriction is chosen.



Line or Sentence Blocking
You may select either a LINE or SENTENCE mode of blocking text in the searched files.    If 
LINE blocking is selecting, boundaries for context data displayed with matches that are 
found will be based on text lines delimitted by carriage return and line feed characters.    If 
SENTENCE blocking is selected, context boundaries will be set according to punctuation and 
white space characteristic of text sentences.    These boundaries are then adjusted to fit the 
available space and to account for any control character that appear in the text string.    LINE
blocking is the default..



Edit Menu

The Edit menu includes commands that enable you to move text to and from the clipboard 
to delete search results text, to insert    clipped text from annother application into the 
results text,    to move results text to another application, and to select the full text of the 
results buffer in preparation for a clipboard operation..

For more information, select the Edit menu command name.

Cut Deletes text and moves it to the clipboard.
Copy Copies text to the clipboard.
Paste Moves text from the clipboard to the edit window.
Clear Deletes selected text without moving it to the clipboard.
Select All Selects all of the results buffer text..



File Menu

The File menu includes commands that enable you to manage the complete context of the 
results buffer ,    easily interact with the Windows clipboard, and to print the results.

For more information, select the File menu command name.

Delete Results Empty the results buffer.
Clip Results Clip the full results buffer.
Print Results Print the full results buffer
Printer Setup Setup the printer options.
Exit FSRCH Exit FSRCH/Windows.



Glossary

To see the definition of any of these terms, select the term and hold the button down.

clipboard
copy
cut
file selector
FSRCH
paste
results buffer
search string
search mode
search option



COMMANDS: 

The    commands provided by FSRCH/Windows are contained in the Edit Menu and the File 
Menu.    For complete information on the commands provided in either of these menus, 
select the menu name from the list below.

Edit Menu
File Menu



FSRCH Options

FSRCH/Windows provides a total of 8 options for controlling the file search process.    Select 
the option name from the list below for complete information on any of the options.

List line numbers
Write Results to File
First match per file
Search subdirectories
Ignore case
Strip bit 8
Show search progress
Show all files



Search Modes

FSRCH/Windows support ten basic search modes.    Select any of the modes from the list 
below to get complete information on that mode.

file names only
string 1 ONLY
string 1 NOT present
string 1 OR string 2
string 1 XOR string 2
string 1 AND string 2
string 1 BEFORE string 2
string 1 BUT NOT string 2
string 1 HEXADECIMAL valeus
string 1 ALL OFFSETS



General Use of FSRCH/Windows
FSRCH/Windows is a powerful file search utility that combines multiple .search strings with a 
wide variety of search modes to allow you find any file by its file name, its contents, or both. 
FSRCH/Windows makes it easy to print the results of a search, output them to another 
application through the windows clipboard, or examine the results directly in 
FSRCH/Windows.

The following simple steps allow you to perform any type of file search.
1. Identify the    file selector pattern to be used.
2. Select a file search mode.
3. Provide one or two search string strings
4. Select the appropriate search options.
5. Click on the OK button to start the search.
6. Examine the contents of the results buffer.

For more information, choose one of these topics.
file selectors
search modes
search options
command



Setting the File Selector

The search file selector identifies a file path and file name pattern that will be examined for 
matches to the search criteria.    Typically, the file selector consists of    a file directory 
specification and a file name pattern including the '*' wildcard character.    Each file in the 
path which matches the file name pattern will be searched.    Optionally, the file selector may
include a disk drive specification to search on a different disk or may omit the directory path 
information to use the current default directory.    

The file selector specification may also be a list of path and file name pattern strings.    In 
that case, each of the specifications in the list will be searched in the order that they are 
listed.

EXAMPLES:
"\MYDIR\SUBDIR\*.DOC" All .DOC file in the indicated directory will be 

searched.
"F*.TXT" All .TXT files whose names begin with 'F'.
"\DEV\*.C, \DEV\*.H" All .C and .H files in the \DEV directory.



Search Strings

The search strings are text strings that must be present    (or absent depending on the 
search mode) in the searched file to form a match of the search criteria..In its simplest form, 
a search string is a contiguous string of characters that must be found in the file.    Wildcard 
characters may not be used in the search strings.    The use of the search strings may be 
modified by the    search options that are used.    For example, the Ignore case option will 
cause strings to match even if there are differences in text case between the search string 
and the string in the file.



Edit Cut Command

The Edit menu's Cut command performs a Windows clipboard    cut operation. on the 
currently selected text in the FSRCH    results buffer    This moves the selected text    from the 
buffer to the Windows clipboard, removing it from the buffer.

KEYBOARD:    The "Shift" string plus the "Del" string, the "Del" string alone, or the stringpad
'-' string may be used.



Edit Copy Command

The Edit menu's Copy command performs a Windows clipboard    copy operation. on the 
currently selected text in the FSRCH    results buffer    This make a copy of    the selected text  
from the buffer in the Windows clipboard and leaves the text in the buffer as well.

KEYBOARD:    The "Ctrl" string plus the "Ins" string or the stringpad '+' string may be used.



Edit Paste Command

The Edit menu's Paste command performs a Windows clipboard    paste operation. over the 
currently selected text in the FSRCH    results buffer    This make a copy of    the current 
contents of the Windows clipboard and replaces any currently selected text in the buffer with
it.    If no text is selected, the clipboard contents are inserted at the current buffer insertion 
point..

KEYBOARD:    The "Shift" string plus the "Ins" string or the "Ins" string alone may be used.



Edit Clear Command

The Edit menu's Clear command performs a Windows clipboard clear operation on the 
currently selected text in the FSRCH    results buffer    This deletes the selected contents of 
the buffer but does not copy it to the clipboard as the cut command does.



Edit Select ALL Command

The Edit menu's Select All command selects the entire contents of    the FSRCH    results 
buffer    This allows CUT, CLEAR, COPY, or PASTE operations to be done on the the full buffer 
at once.

KEYBOARD:    The "Ctrl" string plus the 'A' string may be used.



File Delete Results Command

The delete command deletes the entire contents of the results buffer    This is equivalent to 
selecting the full contents of the buffer and then deleting the selected text

KEYBOARD:    The "Ctrl" string plus the 'D' string may be used.



File Print    Results Command

The print command prints the entire contents of the results buffer.    It may be necessary to 
setup the printer before beginning to print.    This can be done by using the Setup command.

KEYBOARD:    The "Ctrl" string plus the 'P' string may be used.



File Printer Setup Command

The printer setup command allows you to control the print options that will be used for 
future print operations.    After you select this command from the file menu, the system will 
present the standard Windows priter setup window.    Using controls on this window you can 
set any of the following types of printer controls:

print resolution
paper size
paper source
print orientation
font cartridges

Printer setup is not supported in this version of Fsrch/Windows.    Use the Windows Print 
Manager to set up the printer before printing with Fsrch.



File Exit Command

The Exit command causes FSRCH/Windows to terminate processing and exit.    This is 
equivalent to closing the FSRCH Window.



List Line Number Option
The "list line numbers" option is a checkbox that controls whether or not the line number 
associated with string string matches are recorded in the results buffer.    Although line 
numbers are only truly meaningful for ASCII text files, FSRCH will assign line numbers to any 
type of file based on the occurrences of end of line characters.    These numbers only provide
relative position information for other types of files.



Write Results to File Option

The "write results to file" option is a checkbox that controls whether or not the search results
are recorded in a text file as well as in the results buffer.    If this option is selected, 
FSRCH/Windows will prompt you to privide the name of the file that will receive the search 
results.

FSRCH/Windows can search a little more quickly if file output is not required.



First Match per File Option

If the first match per file option is selected, FSRCH/Windows will discontinue searching a file 
once a single match of the search criteria has been found.    This option is useful if you are 
only interested in which file contain a given value or combination of values and not    how 
many occurrences of the search criteria exist in each file.

FSRCH/Windows can search more quickly if this option is selected.



Search All Subdirectories Option

The search all subdirectories option causes FSRCH/Windows to search the directory indicated
in the file selector pattern and then repeat the search for all levels of subdirectories under 
the directory indicated in the file selector.

NOTE:
Take care in using this option with a file selector that consists of a list of file specifications. 
(e.g. "C:\MY_DIR\*.C, C:\MY_DIR\*.H").    The combination of multiple file selectors and 
multiple subdirectories under each one can result in a very large number of files to search.



Ignore Case Option

The Ignore Case option allows FSRCH/Windows to successfully    match letters that are 
different in case.    Using this option lower case or upper case letters in the search strings will
be successfully be matched with the same characters of either case found in the file.

EXAMPLES:
When the case is ignored, the following matches would be made.

STRING FILE TEXT
the text The text
THE TEXT the text
the TEXT ThE TeXt
the text THE teXt
etc.



Strip Bit 8 Option

This option clears the most    significant bit of each byte from the file that before it is 
examined for matches with the search criteria.    This option is useful for files that have had 
the upper bit set to indicate byte parity or for other encodings that modify this bit (2**8).    
Most users will not need to use this option for any searches.

FSRCH/Windows can search more quickly if this option is not selected.



Show Progress Option

The Show Progress Option controls the display of a search progress window.    If it is selected,
a window describing the file being searched, the search phase, and the current search 
position is displayed.    This option is selected by default.

FSRCH/Windows can search more quickly if this option is not selected.



Show All Files Searched Option

The Show All Files Searched Option controls whether FSRCH/Windows includes a line in the 
results buffer naming each file that is searched.    If you want a full copy of the files that were
searched, select this option.    If you do not want the matches to get lost among the list of 
files, do not select this option.

FSRCH/Windows can search more quickly if this option is not selected.



File Names Only Mode

In "file names only"    mode, FSRCH/Windows will list in the results buffer all files matching 
the file selector.    This mode simply searches for matching file names in the indicated 
path(s).

This is the fastest of the search modes and does not use any search strings.



String 1 Only Mode

In "String 1 Only"    mode, FSRCH/Windows will list in the results buffer each occurrence of 
the string in search string 1 found in any of    the files matching the file selector.    This mode 
searches for a single block of text in matching files in the indicated path(s).

This is the most common of the search modes and uses a single search string.



String 1 OR String 2 Mode

In "String 1 OR String 2"  mode, FSRCH/Windows will list in the results buffer each 
occurrence of either the string in search string 1 or the string in search string 2 found in any 
of    the files matching the file selector.    This mode searches for both blocks of text in 
matching files in the indicated path(s).

This search mode performs a fast, inclusive search using two search strings.



String 1 XOR String 2 Mode

In "String 1 XOR String 2"  mode, FSRCH/Windows will list in the results buffer each 
occurrence of either the string in search string 1 or the string in search string 2 as long as 
both strings are not found in the same line or sentence.    This mode will match strings found 
in any of    the files matching the file selector.    This mode searches for both blocks of text in 
matching files in the indicated path(s).

This search mode performs a fast, exclusive search using two search strings.



String 1 AND String 2 Mode

In "String 1 AND String 2 "    mode, FSRCH/Windows will list in the results buffer each 
occurrence of a text line, found in any of    the files matching the file selector, which contains
both the string in search string 1 and the string in search string 2 .    

This mode searches for both blocks of text in matching files in the indicated path(s).    It 
performs fast, exclusive searches using two search strings.



String 1 BEFORE String 2 Mode

In "String 1 BEFORE String 2 "    mode, FSRCH/Windows will list in the results buffer each 
occurrence of a text line, found in any of    the files matching the file selector, which contains
both the string in search string 1 and the string in search string 2    where the string 1 text 
appears before the string 2 text.    

This mode searches for both blocks of text in matching files in the indicated path(s).    It 
performs fast, exclusive searches using two search strings.



String 1 NOT present Mode

In "String 1 NOT Present"    mode, FSRCH/Windows will list in the results buffer each file 
matching the file selector which does not    contain an occurrence of the string in search 
string 1.    This mode searches for a single block of text in matching files in the indicated 
path(s).

This is an "absence" search mode and uses a single search string.



String 1 BUT NOT String 2 Mode

In "String 1 BUT NOT String 2 "    mode, FSRCH/Windows will list in the results buffer each
occurrence of a text line, found in any of    the files matching the file selector, which contains
the string in search string 1 but does not contain the string in search string 2 .    

This mode searches for both blocks of text in matching files in the indicated path(s).    It 
performs fast, exclusive searches using two search strings.



Hexadecimal Values Mode

The "Hexadecimal values" file search mode will locate a single search string identified by the
hexadecimal values associated with its bytes.    This mode allows you to search for strings 
that contain unprintable or untypable characthers.

EXAMPLES:
When searching in Hexadecimal Values mode, the following matches would be made.

STRING FILE TEXT
61 62 63 64 abcd
41 42 43 ABC
etc.



Offset Encoded Mode

The "Offset Encoded" file search mode will locate a single search string even if it encoded in 
an 8-bit, sequential character set other than ASCII (e.g. EBCDC).    If the characters are 
contained in 8-bit bytes and they have the same relative numeric values as ASCII, this mode 
will match them.

SEARCHES IN THIS MODE ARE VERY SLOW!    It should only be used on those rare 
occasions when non-ASCII character sets must be searched.    When using this mode, avoid 
punctuation and special characters that are likely to have different relative positions in the 
character set.    This mode can also be used for simple coded strings that shift the text 
character value by a fixed amount.

EXAMPLES:
When searching in All Offsets mode, the following matches would be made.

STRING FILE TEXT
abcdefg 1234567
abcdefg defghij
etc.

NOTE:    Most users will never need to use this search mode.    It uses a single search string.


